Decorators transform

Decorators are not currently supported

Decorators are disabled in Babel v6, pending a proposal update – see issue T2645.

Until Babel officially supports decorators again, you might want to try the third-party transform-decorators-legacy plugin, or use Babel v5.

Installation

$ npm install babel-plugin-transform-decorators

Usage

Add the following line to your .babelrc file:

{
  "plugins": ["transform-decorators"]
}

References