ES2015 for-of transform

Compile ES2015 for...of to ES5

Installation

$ npm install babel-plugin-transform-es2015-for-of

Usage

.babelrc

// without options
{
  "plugins": ["transform-es2015-for-of"]
}

// with options
{
  "plugins": [
    ["transform-es2015-for-of", {
      "loose": true
    }]
  ]
}

Via CLI

$ babel --plugins transform-es2015-for-of script.js

Via Node API

require("babel-core").transform("code", {
  plugins: ["transform-es2015-for-of"]
});